Cambridge English Support Site

Technical requirements for BULATS

Avatar

Helpdesk Training Article

Follow

The following table details the minimum and recommended system requirements for administering and running a BULATS Test.  Unless otherwise stated we always recommend the latest version of software, for instance Adobe Reader, rather than a specific version.

Please note that we do specify Internet Explorer rather than the Google Chrome browser.  Chrome has shown some issues when allocating Examiners that do not occur in Explorer.

 

  Minimum Recommended Required for...
Processor 400Mhz, 512KB 800MHz, 512KB or better. Admin and candidate sites
RAM 256MB 512MB or greater
Free hard drive space 2GB 4GB or more
Operating System Windows XP Pro Windows 7 or later
Internet connection speed 512 Kbps per computer 5 Mbps or greater per computer
Web Browser Internet Explorer 8 Internet Explorer 11
Adobe Acrobat Reader version Ability to open a PDF Latest version of Adobe Reader
Adobe Flash Player version v14.0.0.145 Latest downloadable version of Flash
Microsoft Excel Ability of open an Excel file MS Office 2013 or later Admin site
Other Sound Card Admin and candidate sites
Headset with microphone Candidate site

 

If you have any questions about the above please get in touch and we'll be happy to help.

Have more questions? Submit a request